RequirementsΒΆ

Envoy was initially developed and deployed on Ubuntu 14 LTS. It should work on any reasonably recent Linux including Ubuntu 16 LTS.

Envoy has the following requirements:

  • GCC 4.9+ (for C++11 regex support)
  • backward (last tested with 1.3)
  • Bazel (last tested with 0.5.3)
  • BoringSSL (last tested with sha ae9f0616c58bddcbe7a6d80d29d796bee9aaff2e)
  • c-ares (last tested with 1.13.0)
  • spdlog (last tested with 0.14.0)
  • fmtlib (last tested with 4.0.0)
  • gperftools (last tested with 2.6.1)
  • http-parser (last tested with 2.7.1)
  • libevent (last tested with 2.1.8)
  • lightstep-tracer-cpp (last tested with 0.36)
  • luajit (last tested with 2.0.5)
  • nghttp2 (last tested with 1.25.0)
  • protobuf (last tested with 3.4.0)
  • tclap (last tested with 1.2.1)
  • rapidjson (last tested with 1.1.0)
  • xxHash (last tested with 0.6.3)
  • yaml-cpp (last tested with sha e2818c423e5058a02f46ce2e519a82742a8ccac9)
  • zlib (last tested with 1.2.11)

In order to compile and run the tests the following is required:

  • googletest (last tested with sha 43863938377a9ea1399c0596269e0890b5c5515a)

In order to run code coverage the following is required:

  • gcovr (last tested with 3.3)